Temporary downtime

Incident Report for Soderberg & Partners Heartpace AB

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 10:56 CEST

Investigating

We are currently investigating the issue.
Posted Jun 12, 2026 - 10:34 CEST
This incident affected: Performance core.